Updates Forum software updated

Discussion in 'Announcements' started by admin, Apr 5, 2016.

  1. admin

    admin Administrator Staff Member

    This release fixes a number of bugs and issues that were found since the last update. As this is a maintenance release, the vast majority of the focus was an increase in stability.

    Some of the bugs fixed include:
    • Adjust the way admins may update user passwords are updated to prevent accidental changes due to autofill.
    • Remove template editor border radius due to Chrome bug with horizontal scrolling.
    • Add autofocus to the full page login form.
    • Prevent image BB codes from being rendered when they couldn't possibly work.
    • Fix issues with the BB code <-> HTML conversion process involving lists within alignment tags.
    • Improved indication when your search failed or did not run as expected due to containing censored words.
    • Allow case insensitive highlighting of non-Latin characters in search results.
    • Limit nesting in the HTML to BB code conversion to prevent stack overflow errors.
    • Fix various issues with thread tag importing.
    • Fix for template modification disabling not working correctly when imported via style XML.
    • Added a new option to control the thumbnail quality of JPG thumbnails.
    • Added a new unsharp mask filter to the thumbnail process to make thumbnails appear sharper.
    • The cached thumbnail URL is no longer used for album thumbnails therefore changes made to the data directory take effect immediately.
    • Prevented a situation where a video embed could be updated to an invalid URL.
    • Improved some of the custom field display styling on the media view.
    • Implemented spam checking on Gallery comments. Gallery comments are therefore now checked against Spam Phrases and Akismet (where enabled).
    • Prevent a 'Serialized value contains an object and this is not allowed' error when a moderator performs actions on some album related content.
    • Fixed missing rating count icon on thumbnails in "New Media"
    • Workaround for an 'Uncaught TypeError' in the Gallery lightbox when a media title comprises only of numbers.
     

Share This Page